VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi guys first post here.

Driving home yesterday car felt really sluggish. Look behind me and started getting some black smoke. I think I hear some escaping air from under the hood under boost but I check all the intercooler piping and can’t find a leak. In addition the brake pedal is really really soft, right to the floor. I know the vacuum pump contros the turbo and brakes. Could that be it?
Attaching a video of free revving and one load revving. Lots of smoke


Really hoping it’s something small, I love the car but it’s been a problem child recently. I need it to get to work and if I can’t figure it out in the next few days there a really pretty 2013 autobahn I’m gunna snatch.
 

·
Super Moderator
Joined
·
209 Posts
Good diagnosis. . The vacuum brakes and vacuum to turbo are both part of the same vacuum system. Should be easy to locate since it's making noise. Check from the vacuum pump to the brake boost. That's a common one. A temporary fix can be RTV applied over it. That should bring your power back and get rid of the extra smoke.
 

·
Registered
Joined
·
61 Posts
Fantastic idea Rattle Bucket. I will keep that in the back of my mind if I come across that. I had a similar issue but it was a leak in the intercooler piping
 

·
Super Moderator
Joined
·
209 Posts
It can be that too you're correct. Let us know what you find. Do you have a way to test the pressure side for leaks? If not search it there are a lot of threads on how to .
 
1 - 4 of 4 Posts
Top