VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Just Sunday I purchased a Silver 1999.5 tdi Jetta with 171K for $2500...two owner car and I have known both owners for years...now for the fun stuff...I know the car needs a timing belt and all associated tune up parts but for now here is my problems: Interior light doesn't work when doors are opened ( yes I checked to make sure light switch was in correct position). I have a blinking glow plug light and a CEL blinking...where do I start...thanks for welcoming me to the family:thumbsup
 

·
Premium Member
Joined
·
23,902 Posts
Welcome! Take a look at the new owner's checklist.

RE: door interior light. Does opening the passenger door make any difference? If you unlock the car but don't open the doors after about 30 seconds, do the doors relock? If so, you need a new door lock module. See the FAQ section for how to remove the door panel and change it out.

Have the car scanned for error codes and if you post them we can help. It could be many things so start there. Autozone can do scans for free.

The price was certainly right.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
I just checked the door interior light and it does come on when the passenger side door is opened...not with the drivers door open...any idea? Going to take jetta to autozone to get a scan this weekend, I'll post any and all error codes. Thanks
 

·
Registered
Joined
·
278 Posts
Unless the wiring inside the door boot is broken you have a bad door module. They are known for bad solders. Remove the door panel and replace it and you'll fix the problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
So I've checked out the faq page and have come to believe that my light problem is the door micro switch...ordering 3 burgess sealed switches to fix that issue and have spares!! As for the CEL and the GP light blinking...have just gone to autozone and got a p1246 obdII trouble code for lift needle sensor. My wires look good, hose from 3 to 4 looks a bit suspect but would that be an issue? How can I check the sensor resistance and what should I read? Any help to get this thing out of limp mode would be great...!! Thank You in Advance...move post if you need to just let me know where...
 
1 - 6 of 6 Posts
Top