VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I recently change my altenator in my 2003 jetta tdi gls . Since I have Ive come across some issues first of my air no longer blows cold air the rate and force of the air hasn't changed it just is no longer cold . Next my power stering is mouning or squeling when i turn mybe its happening because i bent the rod/hose below it when i took of the pully ? Lastly my dumbass didnt make sure the alt cord was securly pluged in and ran my battery dead while driving this could be another reason . Any help would be appreciated on where to start
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
power steering

ok i was wrong the belt tensioner is vibrating a lil i think i figured out the problem with the power steering the fluid leaked out whe i was fixing it wher do i replace it and how
 

·
Super Moderator
Joined
·
23,902 Posts
It could be a loose power steering hose. Reclamp it or check where the hoses go into the reservoir and pump. The belt is probably soaked with fluid which will make it slip. Don't run the car with low power steering fluid since the air will cause damage to the pump and rack. Top it off with VW or Pentosin generic synthetic power steering fluid. Don't use the stuff at the local parts store.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
location

ok i still am having trouble finding the location of the resevoir for the power steering fluid to be replaced sorry i am all new to this
 

·
Super Moderator
Joined
·
23,902 Posts
Black box on the passenger side with a hose to the rear and a hose to the front. Green cap. It's above the motor mount (to the passenger side of the engine).
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
thanks

Ok thank you so much for your help i beliave i have ever thing close to 100 percent the only problem i have left is air it blows air just not cold air could this be because the battery died or am i going to have to check the compressor what a good place to start or some reasons this could be happing keep in mind the battery died as i was driving it car shut off alt was cord was not completle fastened yes i know i am a idiot just need game plan to try to fix it i live in fl its a lil hot around here
 
1 - 11 of 11 Posts
Top