VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi im a newbie and have a question regarding limp mode.
No problems personally but my
2006 VW passat 2.0 TDI 140bhp BKP 120,000 miles
goes into limp mode after driving for approx 25-30 miles. Around town is fine

Vag shows

Control Module Part Number: 03G 906 018 CD
Component and/or Version: R4 2.0l PPD1.5 G 9627
Software Coding: 0000072
Work Shop Code: WSC 00199

1 Fault Found:
16683 - Boost Pressure Regulation: Control Range Not Reached
P0299 - 006 - Short to Plus - Intermittent


Normally around town boost is fine.
Recently changed the manifold flap as was full of oil and two teeth were missing which blew fuse which also controlled air con. It did this before I changed the flap so the flap is not the problem now.
Also checked and cleaned EGR valve which is ok.

Has anybody any ideas would be much appreciated.
 

·
Super Moderator
Joined
·
23,902 Posts
I don't know if your model has the "smart" vnt actuator with the black sensor on it but check for broken wiring to it. Also check for boost leaks. It's possible a hose has rubbed through. It's also possible a boost sensor or wiring is faulty.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
limp mode

Thanks for the reply
Im not sure either if there is a smart vnt.
I have tried to look for more data on the 2.0 tdi bkp engine to see where things go, like N75 and n249 if it has one.
On the bulkhead there is a black box with about 5-6 rubber hoses going into it.

Cheers

Pastdi
 
1 - 3 of 3 Posts
Top