VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
error codes glow plus 1 2 3 p161a/b/c
p0299 boot pressure control below control limit

Hi guys having issues with my beloved golf right now.
mileage 266k, i couldn't start the car one day so was diagnosed as failed fuel pump under passenger seats.
then it started and it would die on motorway after 20minutes or so of driving almost same location each time, up a hill. it would sputter then cut out black smoke out the back, engine would shut off and id have to pull over on the motorway. got it recovered again this time they said it was blocked fuel filter perhaps so they changed this. then it was fine for few weeks but every time i get to this particular hill it would sputter and almost die out but keep going.engine would be shaking violently and the gas pedal would work and then stop working and then kick back in and work and then loose drive again. as id go up a hill id have my foot to the floor and nothing just revs going down then it would kick back in again if i dropped into 4th. the car would be in limp mode for sure. once this was triggered it does this for about 15 minutes then kinda goes away but reduced power for sure. the rets of the journey car keeps going.

now yesterday out of the blue it engine cuts out again on motorway. now its hadn't fully died like this with engine shutting off for a month or so and not restart. i thought the fuel pump and filter fixed this problem. but yesterday i was stuck on a round about wouldn't start at all. after trying the car periodically it restarted on the 57th time magically. got home tried to have a look at it and the bonnet latch failed!! got it open via some hacks and had a look under the hood. nothing had changed really so didn't understand why it actually konked out yesterday. but i noticed a hose from my air box was split and had come loose. not sure if this vacuum hose would cause the car to shut of but i don't know. i put some tape around it to make it more tight and fit it back in since then it has started and will do short journeys. i even put some v power diesel in it and it was flying. like turbo power was there for a slow car. i don't know what is causing the cut out because i thought that was fixed and now this limp mode followed by misfiring is a mystery to me. seems to initiate uphill. at this exact same location every-time on my journey. i tried approaching that hill in 4th still cut outs. any help appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for your response. Were you getting similar symptoms to me? The jerking definitely feels injector related when it does that, but I thought it was due to some ecu receiving incorrect information due to a boost leak. What symptoms were you getting to narrow it down to your injector. Thank you.
 

·
Premium Member
Joined
·
206 Posts
The best answer for injectors is to read the injector IQs off the computer, that gives you definitive answers on their state. When I had one go, the computer would adjust, economy would drop, performance would drop, it would start missing then die having driven one injector to 2.99 and the other to -2.99.

Poor uphill performance is almost certainly boost problems, since you got a code for such. But without being under your hood, it's hard to say. Beauty of the internet forums, great for blind guesses.
 

·
Registered
Joined
·
2 Posts
Hi,
I had 2 years same or similar problem with my Passat B6 TDI. I said myself I will fix this issue and after 2 years of research and many mechanics nothing. 2 years ago I had EGR changed, MAF, injectors checked and many more and again was the same. I parked my Passat in the garage and bought Passat b8. VW sold me faulty B8 and I sold to another dealer and back to my old B6. with jerking problem. I was inspecting the car and I have notice a leak but I was not sure from where coming because I am not a mechanic. My mechanic told me I need to change the radiator which was false. At the time I have had change the EGR the mechanic who work on the car messed up the centre intercooler hose coming to the throttle body and I wanted to clean around the hose connections. I have realized that the retaining clips are wrongly placed and also one was broken. I cleaned and tried to put in the way should be but I forgot to put the upper side of the hose properly. Started driving the car and the car was jerking all the time. Than I have realised where is the problem and put the hose properly in place and the car stopped jerking. This is not fix for mechanic the owner of the car must do it :). I have change all intercooler hoses cleaned the MAP and now the car works. My jerking problem was when I drive the car with 1800rpm from cold car until reach the optimum working temperature. Also I had problem on motorway with losing complete power and orange coil coming up on the dash, I had my OBD 11 in the car and during driving my wife was cleared the fault and power came back. I have notice car was losing compete power up the hill After I fixed the jerking no problem up the hills. At the last changing the the last intercooler hose coming from the turbo itself I have realised the oil drain of the turbo leak a bit and I watched video on YouTube saying oil drain and oil feed pipes must not leak as will cause many issues. I believe intercooler hoses leak came from bad engine mounts as the vibrations make them to lose and wear the metal connections. If you need more details ask. I hope this will help.
 
1 - 6 of 6 Posts
Top