VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner
1 - 7 of 7 Posts

· Premium Member
Joined
·
9,237 Posts
Hi guys/gals.

Now for the first 4-5 months of having my car I put 283 mp3's on a 2GB flash drive in my RCD310 with different groups in different folders. I made a playlist in WMP all random and it worked great. After this time I noticed that the tracks weren't very random even though the random option was selected, in fact it appeared to only play in one sub folder. I formatted the drive and reloaded but still only played one folder. I moved all files into the drives root and deleted the folders and the playlist now it plays as it used to randomly. I don't know why it changed after 5 months.

I found a Volkswagen Media Device Interface (MDI) Firmware Upgrade 0111 KW22-2010, considering this is a firmware update after week 22/2010 I think I may give it a go to see if it cures my problem.

I'm not sure what it means on the site?
VW MDI KW22/2010 Firmware (primary download site – this will have the latest if there are any updates so if you want a specific version use the link below)

VW MDI KW22-2010 Firmware

(This file needs to be renamed from mdi.bin.kw22-2010.enc to mdi.bin.enc. You may not see the .enc extension so this is nothing to worry about – just remove the version number “.kw22-2010″ and proceed with the update)
Now both downloads are the same date but the first one has the latest updates but the second has specific versions. I does give the error codes if the version is older then installed.

Does anyone else have MDI problems? Your thoughts are welcome.

I've said this before this is a useful site to have in your favourites for tricks & tips. ;)

Cheers.
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #2 ·
38 users have read this thread but no comments.

I've put the latest update in I rebuilt the flash drive with the sub folders and it still plays every track in the first folder (BOSTON) so this update has done sweet FA. :mad:

I've put all tracks back on the root and it plays random again.
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #4 ·
Cheers for replying golfTDI1.

Yes I plugged the flash dive in turned on the ignition then switched the radio on and it said something like "update initializing" then a couple of minutes later it said "update successful". Yes it was a blank flash drive that I used.

Well as I said before for the first 4-5 months of use using seperate folders it played great and everything was random in each folder.

Now I just read a post on another forum that I can't post because you have to join to read. Someone is have problems with his iPod in an RCD510. ;)
Although this subject has been referred to before, I don't think anyone's raised this particular issue with the MDI and an Ipod.

I've been using a plain usb with the RCD510 with no problems but recently got hold of a 160GB Ipod classic. Loaded with about 15GB's of music and first time I plugged it in using the MDI lead - bingo, it worked instantly.

Next three or four times, again it worked perfectly until yesterday when it seemed to 'freeze'. The RCD screen just shows 'AUX' and the dash display says 'please wait' Stayed like that for 30 mins, nothing happened.

Also the Ipod screen didn't switch to the display with 'OK to disconnect' which came up when it worked.

Unplugging / pugging back in didn't work.

The USB still works fine, but I preferred the Ipod's functionaility.
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #5 ·
I took it in for its first service today and asked them to look at what it only plays one folder on the flash drive. After the service I went out with the technician so I could explain what doesn't happen. Now it appears there are three play options, play, random folder and random mix. It was on random mix and it was playing different tracks like it used too. He said when he first tried it it was on random folder so it was playing random tracks in that folder.

Well its been 12 months since I first read the handbook and I'm sure I set it to random mix I can't remember changing buttons since once things are working properly I leave them along. So this was my fault really for not reading the handbook again its now working as it used too.

I was reading somewhere that a user updated his firmware to the latest and when he took it into the dealers for something else they must have noticed now he says is warranty is void for doing his own updates. Well they didn't say anything to me. ;)
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #7 ·
I haven't had much luck with this setting. It is set to "on" but the unit still only randomizes within a folder. Do you (or anyone) have tips on getting the unit to recognize the file structure to play between folders...?
Well I didn't have any problem I downloaded mdi.bin.kw22-2010.enc and put it on a blank flash drive, I think the radio is set to read *.enc files. I plugged it in and it showed installing after a minute or so it was done. Now I haven't noticed any difference with this firmware update but others on other forums have?

On my RCD 310 you can switch button to select what you want to play, all tracks, random folders, random files.
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #9 ·
I don't have an SD slot on my RCD 310 so I used a flash drive and it worked. You don't say which radio model you're trying to update?

I don't know that a playlist will make any difference if you follow the instructions on my Firmware update link, plus how are you going to add a *.enc to a playlist its not a media file?
 

· Premium Member
Joined
·
9,237 Posts
Discussion Starter · #11 ·
That link doesn't say which radios the update is for and it only talks about a flash drive not an SD card. Don't you have a USB media cable?

Well my radio handbook says it can use a playlist so I made one not long after getting my car and the tracks play just the same. I've deleted the playlist and the tracks still play the same, I have mine set on Mix All so all tracks and folders are random.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top