VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
VW Golf 4 TDI 4motion 85kW 115HP 2001
I had a failing MAF (Bosch 0 280 217 121), tried cleaning it and wouldn't help. Replaced it with an aftermarket MAF, which showed up in the car parts catalogue as an alternative (and 3x cheaper than the OEM stuff). Things seemed to improve a lot, car had some of it's power back, but it never felt like it was as it was when everyhting was good. I had it serviced and the guy told me that this MAF is working, but not very correctly, thats why I get low power @ low rpm, and also higher fuel consumption... EGR is still there but the vacuum hose has been closed shut. No changes in the ECU regarding EGR removal haven't been done yet. When logging with VCDS, I get these graphs:

8363


8364

It really feels like it lacks power when starting to move, and only when above 1500-2000 RPM it only opens up.
Could someone confirm that the MAF I have is wrong for my car and I need exactly the one I had?
 

·
Premium Member
Joined
·
83 Posts
It's no question you need the OEM parts for them to work properly. After market just isn't worth it. Yeah it's $78 or $120 depends on where you go. Find the actual part number and search...

$120


Or $78

Sent from my moto g(7) power using Tapatalk
 

·
Super Moderator
Joined
·
9,224 Posts
First posts normally go in introductions else you could get a free fix and we never see you again!!!

Forum Rules and Guidelines

This is a new forum layout with loads of bugs which have been reported in the new thread. There is no TDI Wiki at the moment or original similes. It doesn't show the car spec/location or signature properly either

We Are Live - Community Feedback

This has been talked about many times.

I've made a pole which no one has posted in, there are a few votes and comments.

Do you like the new forum features?

Wiki pages have been restored as of 7th December, I asked where is the link it should be on top of the main forum.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
So I replaced the wrong maf with OEM Bosch and everyhting's fine now. Originally I had Bosch 0 280 217 121 but as it is discontinued I got a replacement Bosch 0 281 002 757. Turbo boosts a lot sooner now and my Golf is alive once again!




As you can see in the images, MAF shows correct values finally (note, the EGR is removed thus it shows a bit more), and turbo reacts quicker because of this.
 

·
Premium Member
Joined
·
83 Posts
Glad you got it fixed.
VW and Toyota are both really bad about requiring OEM parts for them to work properly.
We think we'll chat and end up spending more in the end. Just don't do it...
Find an OEM supplier and buy their parts at a fraction of the price, but don't buy another manufacturers parts...

Sent from my moto g(7) power using Tapatalk
 
1 - 5 of 5 Posts
Top