VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi im new to this forum so hello everone.

I have a SEAT Leon FR tdi 150 PD with engine code ARL which I have only owned 3 weeks. I have some turbo chatter when I lift off the throttle. Its quite loud and is annoying me. I believe they all do it to some extent but mine is loud. I have tried the following already and have mentioned other repairs which are not related.

Decat - made no difference to noise
Pipercross filter - made noise louder unsuprising really
Camshaft and followers - no difference to noise, changed because of slight wear
Full service incl all filters - no difference
Checked boost hoses for condition all good
Checked VNT by removing actuator and feeling for stuck vanes, free as owt
Checked VNT actuator by getting a mate to rev car, seems to move rapid and free
Checked VAG COM - no faults
Boost map shows slight overboost

Any ideas?

I am thinking along the lines of bad N75 or ECU map which is a very long shot.
 

·
Premium Member
Joined
·
9,674 Posts
Welcome to the forum Mark. welcometomyturbodies

I suggested you should come here and you've arrived. I believe you talked to John today because had had a similar noise and they changed the turbo under warranty on his?

You could add 2005 to the car spec for reference. ;)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Welcome to the forum Mark. welcometomyturbodies

I suggested you should come here and you've arrived. I believe you talked to John today because had had a similar noise and they changed the turbo under warranty on his?

You could add 2005 to the car spec for reference. ;)
Hi Keith. Yep his car still has this noise too even after a new turbo! I can't believe it could be just how they are supposed to sound! Its not a nice sound, like a little dog bark is another way ive heard it described.
 

·
Premium Member
Joined
·
9,674 Posts
Hi Keith. Yep his car still has this noise too even after a new turbo!
I don't remember you saying you bought a new turbo only you stripped it and it looked ok?

Oh and you didn't say its a VAG-COM clone using VCDS-Lite did you?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I don't remember you saying you bought a new turbo only you stripped it and it looked ok?

Oh and you didn't say its a VAG-COM clone using VCDS-Lite did you?
Your mate John had a new turbo and still has the same noise so im not gonna be putting A new turbo on mine to try to fix it! Yes I have VCDS freeware not full version. Anyone got any ideas yet?
 
1 - 7 of 7 Posts
Top