VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I am Joe. I live in Pahrump, 60miles west of Las Vegas, Nevada. I just joined MY turbo diesel. I have been very impressed with the help and access to information. The manual shift linkage was a life saver; especially because, the engine I just put in was taken out by someone else. I have 3 jetta TDI's. They all have the MIL on. My 2001 is the sickest. It has no power and black soot all over the back of the car.
Codes set are:
17964, Charge pressure control: Negative Deviation P1556-35-10--Intermittent
18057 Power Train Data Bus: Missing Message from ABS controller p1649-35-00
17664-Engine Coolant Temp Sensor (G62): Open or short to Plusp1256-35-10 Intermittent
16764-Glow plug/Heater (Q6) Circuit malfunction p0380-35-10--Intermittent
16485-Mass air flow sensor (G70): Implausible signal p0101- 35-10--Intermittent
I have VCDS and this is how I retrived the codes. Tests show that the engine is running @72C although the engine fan comes on and goes off; possibly the sender?? The gauge works; reads 190. Mass air flow sensor is bad. the tests show that they are way above400 and they do not keep up with one another; pedal vs sensor. I am kind of lost as far as 17964. The turbo actuates just fine; with applied vacuum, the rod moves freely. When the accelerator pedal is pressed, the car has a dead spot about 1800-2200 RPM and then revs to 4800 and stops there; it does not tach out @5500. Any help would be appreciated. Thanks Joe
 

·
Premium Member
Joined
·
23,902 Posts
Even though the instrument cluster gauge could be OK, the one going to the ECU could be bad. Check coolant temp engine measuring blocks through VCDS to see 3 temps: one on a totally cold car (all should show ambient), one while warming up, and one while warm.

You mentioned a bad MAF and ruled out a bad actuator and rod, fix that first before worrying about the other codes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I changed out the MAF, and the temp sensor. Car continued to miss and blow out black smoke. I decided to check the intake, pulled off the hose and looked into the intake. It appeared to be some what blocked so I took it off. Well, as you can guess, it was all plugged up; it looked just like your picture on intake cleaning. I cleaned it up and reinstalled. The car runs great!!!!! Thank you for all your help. Your forum is the best.
 

·
Registered
Joined
·
1 Posts
Hello
17964, Charge pressure control: Negative Deviation--- here you have vacum leaks from N75 to Vnt actuator
17664-Engine Coolant Temp Sensor (G62) --- the coolant senzor is defective , you must change it
16764-Glow plug/Heater (Q6) Circuit malfunction p0380-35-10--Intermittent---- did you change or put another dashbord?
16485-Mass air flow sensor (G70): Implausible signal p0101- 35-10--Intermittent--- Maf senzor is defective, you can try to clean it up but the chance too work good is very small
 
1 - 4 of 4 Posts
Top