VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 20 of 22 Posts

·
Super Moderator
Joined
·
23,902 Posts
Discussion Starter #1
This should also apply to the VW Jetta TDI. A Ross tech VCDS cable and software is required. Long story short, adjust channel 13 in the CECM adaptation. While you're in there you can also set it to all doors open with one press of the unlock button or unlock the doors when you pull the key out of the ignition.

Here is the full article and screenshots:

http://www.myturbodiesel.com/1000q/a6/change-number-blinks-turn-signal-vw.htm
 

·
Registered
Joined
·
189 Posts
This should also apply to the VW Jetta TDI. A Ross tech VCDS cable and software is required. Long story short, adjust channel 13 in the CECM adaptation. While you're in there you can also set it to all doors open with one press of the unlock button or unlock the doors when you pull the key out of the ignition.

Here is the full article and screenshots:

http://www.myturbodiesel.com/1000q/a6/change-number-blinks-turn-signal-vw.htm
Good stuff! :) Thanks! :+1
 

·
Registered
Joined
·
85 Posts
FYI, you can set the "unlock the doors when you pull the key out of the ignition" from the MFD too.

I did that for mine because I was tired of having to unlock the car again when I get out, just to open the hatch.

Just in case anyone was wondering, :D
 

·
Registered
Joined
·
11 Posts
Unlock doors upon key withdrawal is awesome

FYI, you can set the "unlock the doors when you pull the key out of the ignition" from the MFD too.

I did that for mine because I was tired of having to unlock the car again when I get out, just to open the hatch.

Just in case anyone was wondering, :D
Thanks for the tip. I got out my manual and was able to set all my doors unlock when key is removed (even the hatch). I really like this setting, but would have to consider carefully whether to do this if my kids were still young (now 18 and 25). Thanks for sharing! R. :thumbsup
 

·
Registered
Joined
·
100 Posts
FYI, this turn signal mod does not work on some (if not all) '11s. It won't work on mine. The VCDS does change the number value in the adaptation, but the car just laughs it off and keeps blinking 3 times anyway...
 

·
Registered
Joined
·
66 Posts
FYI, this turn signal mod does not work on some (if not all) '11s. It won't work on mine. The VCDS does change the number value in the adaptation, but the car just laughs it off and keeps blinking 3 times anyway...
Could there be some other setting which is overriding the 3 blink setting?
 

·
Super Moderator
Joined
·
9,323 Posts
Well in the UK there is a set requirement for the flash rate of indicators it has to be between 1 and 2 times a second. If the default is 3 then that seems a bit slow.

Oh we now have the dredid 666 post count. :panic:
 

·
Registered
Joined
·
23 Posts
Keithuk, not the flash rate, but the number of flashes for a signal 'tap'

I could swear I saw a #flash adjustment in my us golf mfi setup as well. Or maybe that was the drl setting (which is def avail in mfi)...
 

·
Super Moderator
Joined
·
9,323 Posts
Keithuk, not the flash rate, but the number of flashes for a signal 'tap'
Ok I'm with you now on that point. I've read on other forums that a number of users want to increase the number of flashes it makes. I wonder if anyone has investigated this?

Again this is yet another topic needed in VAG-COM/VCDS User Locations ;)
 

·
Registered
Joined
·
100 Posts
Could there be some other setting which is overriding the 3 blink setting?
Nope. Others have run into this "brick wall", too.

Keithuk, not the flash rate, but the number of flashes for a signal 'tap'

I could swear I saw a #flash adjustment in my us golf mfi setup as well. Or maybe that was the drl setting (which is def avail in mfi)...
The only adjustment for "comfort" flashers in the MFI is the one that turns the function on or off. If you turn on the function in the MFI, but are not happy with three flashes, you'll need VCDS to change the number of flashes to anything from one flash to five flashes. It's just that some (all?) 2011s don't respond to your new setting and continue to flash three times no matter what the setting is. My car is like that...

Ok I'm with you now on that point. I've read on other forums that a number of users want to increase the number of flashes it makes. I wonder if anyone has investigated this?

Again this is yet another topic needed in http://www.myturbodiesel.com/forum/f10/vcds-vag-com-section-here-3918/ ;)
See above...
 

·
Super Moderator
Joined
·
23,902 Posts
Discussion Starter #12
Hey, this issue has been driving me crazy -- I bought a cable from Rosstech in large part because I wanted to change the # of flashes to 5 on my 2011 Golf TDI.

I think I found a solution though -- see here: http://forums.vwvortex.com/showthread.php?5006547-Change-comfort-turn-signals-count-in-MKVI&p=70054737#post70054737

Tell me if this works for you guys.
Please try it and lets us know if it works :) This step is not clear:

3. At the prompt "Set to factory settings for lights & vision?", select OK.

4. Marvel in amazement as the turn signal magically flashes 1, 2, 4, or 5 (yes 5) times.
 

·
Registered
Joined
·
8 Posts
Please try it and lets us know if it works :) This step is not clear:

3. At the prompt "Set to factory settings for lights & vision?", select OK.

4. Marvel in amazement as the turn signal magically flashes 1, 2, 4, or 5 (yes 5) times.
My Golf has an option under the dashboard MFI in the settings menu to reset to factory defaults. If you select this, I think it does some kind of reset on the ECU -- would explain the sporadic reports of people having success by flashing it multiple times, starting/shutting off the engine, etc.

Edit: also, yes, it works on my car, I'm the guy who found that solution :) Wondering if it works for everyone who was having trouble, so I crossposted here. This site has been a huge help for me -- chitty you've done an awesome job collecting all this information in your 1000q's, and it's been an invaluable resource for me, a new VW owner!
 

·
Registered
Joined
·
22 Posts
My Golf has an option under the dashboard MFI in the settings menu to reset to factory defaults. If you select this, I think it does some kind of reset on the ECU -- would explain the sporadic reports of people having success by flashing it multiple times, starting/shutting off the engine, etc.

Edit: also, yes, it works on my car, I'm the guy who found that solution :) Wondering if it works for everyone who was having trouble, so I crossposted here. This site has been a huge help for me -- chitty you've done an awesome job collecting all this information in your 1000q's, and it's been an invaluable resource for me, a new VW owner!
So you DO need the cable? Resetting the factory settings just lets the cable do the magic? Or does resetting the factory settings open up a menu? This sounds like a very interesting mod.
 

·
Super Moderator
Joined
·
9,323 Posts

·
Registered
Joined
·
8 Posts
So you DO need the cable? Resetting the factory settings just lets the cable do the magic?
Precisely. You have to change the number of blinks just like you would normally using vcds.

But hitting the factory reset causes the new setting to "take".

This only seems to be necessary for the 2011's. It works on my car every time. I'm wondering if this is a general fix for all 11's that people were having trouble with.

Furthermore, (and this is the really intriguing part to me) I wonder if there are other settings that cannot otherwise be enabled in vcds that can be accessed with this general procedure (vcds + factory reset).
 

·
Registered
Joined
·
8 Posts
I changed my tap flashes from 3 to 5 a couple of weeks ago and it worked. Have a read of How to change the number of blinks the turn signal makes per tap on your mk5-mk6 VW and CECM adaptation.

Though it did turn my DRLs back on which I turned them off manually, it could have been a coincidence. ;)
Yes, you have to follow this procedure in any case. Since you have a 2010, you were done. :)

But many folks with 11's were finding that this didn't work. I found that the extra step of a factory reset from the MFI caused the new setting to work.
 

·
Super Moderator
Joined
·
9,323 Posts
I would have thought logically that the factory setting in the MFD would mean it switches all settings back to the factory default settings not to enable the settings you have entered?
 

·
Registered
Joined
·
8 Posts
I would have thought logically that the factory setting in the MFD would mean it switches all settings back to the factory default settings not to enable the settings you have entered?
You and me and everyone else, buddy :)

My thinking was that there's a bit of a bug with the 2011's, and people had had some success by flashing multiple times, cycling the ignition, etc. The other thing I was going to try was briefly (<1 sec) disconnecting the battery -- I bet that would work too. But this is a more elegant workaround. For what it's worth, I'm not 100% sure what the factory reset really is intended to do. I have VAG'd a bunch of things, like LED tails, coming home, etc., and it left all that stuff untouched. :dunno
 
1 - 20 of 22 Posts
Top