VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, Can some one help with a problem i got with my passat.

I have a passat tdi Pd engine and i having a problem with engine shake, vibration only when idling.

I have no loss of boost power, Cant find any pipe leaks, cars not over smoking and no knocking ticking or any cam wear noise. Just a shaken engine which go if i push on the acceleration just a bit to up the rpm.
I can really feel the shaking from inside the car apart from the gear stick & steering wheel vibrating.

Things i tried are: looking for pipe leaks, looking at engine mounts, (they look fine) cleaning the egr valve, cleaning the maf sensor.

I have also connected a vagcom. no codes recorded and i looked at cam timing which was a little out. so i adjusted but make no difference at all apart from getting a bit more MPG.

Injectors are a little under par but still with in spec.
I don't no what ells it could be? The engine as been well serviced. Fuel filter was change about 1200 miles ago (could it be that) engine oil looks like it could do with a change. That is my next job but i don't think it will help.

I think its the fly wheel as it doesn't get any better if i put the clutch down.
Air com turned off it's still the same.

My friend as a passat same model and his engine doesn't shake vibrate any were near the level my passat does.

any help on what could be the problem.

Thanks
 

·
Premium Member
Joined
·
150 Posts
I might add even a bad engine mount or loose hardware could cause the vibration.
Bad injector or valves might need to be adjusted. Tho i think you said you checked thos right?
Think i also read somewhere that uneven compression will cause vibration at idle?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks for all the fast reply's.
I had a CV joint done 2 weeks ago. It can not be that as its a manual and shakes when not in gear.

After looking on youtube at balance shaft chain i not sure if it could be this. after looking at the engines on over cars, there engine doesn't vibrate as much as mine and there is a faint rattle sound which i don't get from my. ( could my still be this problem? )

Could it be cam shaft problem or valves? would i get any loss of power from this? my car has no loss of power and drive all most spot on apart from a little misfire in 2nd gear with low rpm before boost but this only happens some times and only in 2nd gear.

I could take the rocker cover off to look for cam ware. could uneven compression be the problem? i thought i would see loss of power if it was this?

I will try to take off the serpentine belt to see if this helps but all belts are looking fine with no wobbles with the engine running. Timing belt was changed just over 20000 miles 135000 on the clock now

Don't think it the engine mounts. I can't see any leakage in them also the engine doesn't move when revving.

I could just live with the problem but just don't wont to course more damage by leaving it.

The vibrate is that bad it makes the cover rattle and if i could to put a cup of tea on top of the engine it would empty the cup.

If i would up the idle rpm from 860rpm to 950rpm using vdcs the vibration would probably go.
 

·
Premium Member
Joined
·
23,902 Posts
That is too much vibration, probably not the balance shaft chain although it's certainly possible. If this were the case, the balance shaft could be thrown off. I think your engine is a 1.9L though so it shouldn't have a balance shaft so that's not a problem!

I don't think you can change idle using VCDS. My best guess: bad engine mounts but as you said, the engine doesn't move when revving. However, the engine mounts have historically been a weak point.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Still no luck :dunno

I'm beginning to think my problems is just the idle being set to low. 830rpm ? is this to low?

I been reading that the idle should be 903rpm is this true? if i set it the idle to 903rpm the engine vibration almost go's and it looks just like a diesel should.

I only have the free version of vdcs and i cant save the new idle speed. Is there anyone that would help with this? ie is the a different program that let you do it with out buying the full version.
 

·
Registered
Joined
·
1 Posts
I am having the same problem with my 06 Jetta. Started at over 70k. Did a timming belt at 80k and it is the same. It only does it at idle when it is warm. Kick up the idle with the pedal and it goes away.
 

·
Registered
Joined
·
2 Posts
shakeness solved

hi,i own a4 b6 from last 10years never had any problem,but last month i bought altea 2tdi bkd,and it has exactly same problem of shaky shaky on trafic light,i was scratched my web for about 3weeks,but doesnt find any help,so i went to my mechanic(one from 10years)and he cure the problem,now no more shake,ok so the problem he found was alternator pulley,that he replaced it and fixed the problem,these new engines hav diffrent kind of pulley that have two gears,and after some time it start creating problem,and its not very expensive either just 39pounds from trade and 30pound fitting,i had looked so many people advice about cam timings pls pls dont mess with timming.hope it helps.
 

·
Registered
Joined
·
2 Posts
more explanation

problem before,when cold no vibration and shakeness,as temp goes to 90 it start shaking,it feel more like low idling timing,but it solved now after changed alternator pulley.thanks to my genius mechanic,being his customer from last 10years.ta
 

·
Registered
Joined
·
1 Posts
Has anyone else had similarr problem that got fixed some other way? I have a 2006 Jetta TDi with 67k
on it and does the same thing as u guys described. Smooth when it's cold and gets shaky after a long drive I stop at a red light. Quite annoying.
Thanks
 

·
Premium Member
Joined
·
23,902 Posts
Has anyone else had similarr problem that got fixed some other way? I have a 2006 Jetta TDi with 67k
on it and does the same thing as u guys described. Smooth when it's cold and gets shaky after a long drive I stop at a red light. Quite annoying.
Thanks
Check cam for wear or check timing. 90% one of these problems.
 

·
Registered
Joined
·
2 Posts
Did you ever figure out the problem? My 00 TDI beetle does the same thing and i cant figure out what is going on with it. It shake like crazy at idle but once i press the gas pedal a little or drive it run perfectly smooth
 

·
Registered
Joined
·
2 Posts
Fixed

Did you ever figure out the problem? My 00 TDI beetle does the same thing and i cant figure out what is going on with it. It shake like crazy at idle but once i press the gas pedal a little or drive it run perfectly smooth
I dropped down my IQ and all shakes are GONE! So, happy with the car now :)
 

·
Registered
Joined
·
1 Posts
Please i have this similar problem with my 2001 passat. as soon as the car begins to idle, vibration will commence in the cabin. however, the vibration goes away the moment i give it gas. it vibrates when the car rpm is below 1000. i have changed all the mounts, in fact the last i did was to change the front mount, yet the vibration continues. it actually started low but now it's very bad. please i need help.
 

·
Registered
Joined
·
7 Posts
I'm too having this problem with my 2007 mk5 Golf. From the moment I start the car, cold or warm its vibrating badly on idle. Like said in previous posts once the revs rise its fine smooth and quiet, but on idle sat at lights or in traffic its horribly loud. It all most sounds like its the exhaust but checked all this out and its fine. Can anyone help?? Please its doing my head in now and it seems to be getting worse!!
 

·
Registered
Joined
·
1 Posts
I searched for this problem and found this forum. I had purchased a 2006 VW Jetta TDI new and after about 10,000 miles vibrations at idol began. we took it in for repair attempts 15 times. they replaced just about every part that could be associated with the issue with no luck. they were talking to corporate and even the engineers in germany. VW finally told me to go away. literally. so we sued them and won. they never solved it.
 
1 - 20 of 24 Posts
Top