VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

First Post and I'm stuck in Limp mode

3534 Views 7 Replies 6 Participants Last post by  Seatman
Both me and my TDI have gone into limp mode sadly.

I read this article http://www.myturbodiesel.com/1000q/multi/limp-mode-TDI-fix.htm and it seems as though I might have throttle pedometre problems but not really sure where to start. Firstly the cars been leaking into the O/S side rear foot well and i have no idea where thats coming from, the footwell had an inch of water on Friday last week which has also made the front drivers foot well wet.

Yesterday i was running low on fuel the light was on and it went into severe Limp mode only revving to 1200 RPM. The coil light is coming on and the car will now only drive at 5mph. To start with after re-fueling I realised if i restarted the car it cleared the problem, but as soon as you hit the brakes it comes back! so i know its a throttle and brake pedal issue. If anyone can tell me where to start with this i would be very greatful, i was hoping to take my girlfriend away for her birthday next week. I dried the car out last night and disconnected the battery to reset the ECU, but today its worse in that when starting it stuck in limp mode straight away.
1 - 8 of 8 Posts
The fact that you can only rev to 1200 rpm combined with the flooding suggests a bad accelerator pedal. Before you replace it, get the car scanned for codes to confirm. This is the sort of thing which definitely should throw the code.

I assume you used a wet/dry vacuum to suck out as much water as you can and then stick a dehumidifier in there with the windows closed. You need to get out as much moisture as you can or else the grounds inside the car can get corroded.

Water leaking is normally from the windshield drain area (check for leaves), sunroof drains at the corners of the sunroof (look for the FAQ article), or windshield gasket. The fact that the rear foor well is wet suggests a sunroof drain which is clogged and backing up into the interior. An inch of water is a bit much though.

The pedal could be a red herring so make sure to look over all the common causes of limp mode in your TDI to make sure it's not something simple, good luck!
Try taking the pedal off and cleaning the contacts. Maybe there's some corrosion that you can see.
Thanks guys, ive managed to dry the floor as much as possible, although still none the wiser to where its coming from. The pedal area feels dry but i cant see where the push rod at the top of the pedal goes once its the other side of the bulkhead. The problem is still the same this morning in that when you start the car its fine but as soon as you depress and take your foot of the foot brake the throttle becomes unresponsive, how are these connected, any idea where the throttle sensors are?
Check the brake pedal sensors too. If the brakes are on it kills the throttle like you describe. The car uses drive by wire, there is no push rod going through the bulkhead. If the brake switch is bad the car thinks you're stepping on the brakes and stops the drive by wire throttle.
Thanks for that Miker, any ideas who I get to those sensors?
Thanks for that Miker, any ideas who I get to those sensors?
Your water prob is under the battery in the bulkhead where it is placed. there is a drain off below it which goes to the bulk head below exiting roughly in line where the gear linkage is, (you will find a rubber flap). remove battery, clean hole, prob solved. VAG DEALERS GHARGE A FORTUNE TO SOLVE THIS COMMON FAULT. HOPE THIS HELPS.
It might be worth making sure your ecu is dry and not all soaking like mine was. I read on another post on here about the passat ecu being below the windscreen. That's where mine is too and it was soaked, I was getting a throttle positioning sensor problem and limp mode on a regular basis. Once cleaned and dried though my car ran sweet thankfully. It seems the ecu is tougher than I thought it would be.
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.