VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have 06 jetta w/dsg and changed trans fluid about 2 months ago. I also changed DMF about 4 months ago. All is good until recently.
Problem:
When driving (cold or warm trans) the shifting is abnormal. Sometimes when driving easy/normal the car will shift as expected from 3-4 and 4-5 and 5-6 but other times its been high revving before it makes the shift - ex. normally shifts around ~3k but when it tries to shift it will free rev to ~4.5k before it will shift to next gear. This doesn't happen when downshifting but only when upshifting. It seems to get worse (more frequent as few days go by) and before this had happened I've noticed at times a small/faint click or clunk noise when it shifts if radio off and window down, still hear it little here and there as have for past 3+weeks, not sure if its a concern or if this is normal. When I'm driving i try to let off gas when its to shift to avoid the free rev but cant always avoid and it shouldn't happen.

Could i be low on trans fluid? Could my mech unit be going out? Any input is appreciated..
Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
i used one of the methods in the DIY guide; drain fluid, replace filter, built my own tool to fill, put all 6 bottles in and warmed up trans to ~95 deg (using infrared non contact temp gauge), disconnected hose and let about 1 qt drain out (once it slowed down i plugged hole). Not sure how accurate the infrared gauge i used is but i used it.. If it was hotter than what it read, prob more fluid came out than was required. think i can add little through filter hole and see if it helps?
 
1 - 3 of 3 Posts
Top