VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
On my 2010 Golf TDI, at about 750 miles, the check engine light went on two days ago. I went to the dealership today, to have some other work done - replacing a door panel, so the timming was good.

They told me that code had to do with an oxygen sensor, and they reset the light. They said to drive it and see if it comes back on again. They said if it did, they would need the car for at least a few days.

I did a lot of driving this evening, and late tonight it came back on again at 950 miles.

Has anyone else had this issue? What am I in for?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
It is at the dealership. They ran diagnostics again, and told me that they are replacing an O2 sensor. They sent me home in a 2008 White Rabbit (gasoline) loaner, and I should get it back tomorrow. Hopefully this does the trick.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
They replaced an O2 sensor, and I am at 1300 miles. So far so good.
 

·
Registered
Joined
·
7 Posts
Check engine light turned on at 1700 miles. Dealer says they have to replace oxygen sensor and some harness associated with this sensor. Takes couple of days to get replacement part.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Hi ChipGuy. I am at a little over 2000 miles, and have not had a problem since they replaced an O2 sensor in my Golf at 950. Interesting that this seems to be an issue.
 

·
Registered
Joined
·
7 Posts
Check engine light came on at 865 miles. I had it set up for service on Sat. due to one of the keys not working, "key out of range". So I will find out what it is Sat.
 

·
Registered
Joined
·
7 Posts
Had the car checked out. The key had a problem because the dealer did not tighten the battery cables and the check engine light cleared before we had our appt at the dealer and no codes were set in the ecu.
 

·
Registered
Joined
·
17 Posts
Coil light flashing

Was driving around today when the "coil" light started flashing at 950 miles. Turbo was inop so the car was in "limp mode". Turned off car, restarted and was fine over the next 20 miles at which point I was back home. I connected an OBD engine anlyzer under the dash and it read "amber" with no codes. Amber is what it would read after the battery had been disconnected but I have never touched it. Weird. At 950 miles, it should read green or have a fault and be red.

I experienced a similar issue on the 2 Jetta TDIs in the past and on both of those it was the mass air flow sensor. Both showed this when checked with the OBD analyzer. On both of those, restarting car retored the turbo for like only a 1/4 mile then back to limp mode.

On the Golf, this "coil" light is the same glow plug wait light on the dash that comes on briefly when ignition is turned on. Owners manual says flashing = diesel engine malfunction. Nice. So I'm off to the dealership in the morning and miss work because of it.
:BS
 

·
Registered
Joined
·
68 Posts
Do you have an aftermarket radio? The ross tech cable LED shows amber or red when the connection is not good. I think there's something about it on their site and aftermarket radios.
 

·
Registered
Joined
·
7 Posts
The check engine light came back on again today at 2035 miles. So I stopped by an auto parts store and had the code read. It was P013B, So we will be calling the dealer tomorrow to let them know.
 

·
Registered
Joined
·
17 Posts
On mine, turned out to be a bad EGR valve which was replaced under warranty :confused:
Those can go bad but should not at 1k miles of course. Hopefully, thats the last of the manufacturing hickups.
 

·
Registered
Joined
·
7 Posts
Check Enginer Light

Check engine light turned on for the second time at around 5100 miles. Dealer first said it was the rear oxygen senor (first time it was the front oxygen sensor) but later on said the sensor hardware is fine. They upgraded ECM software per factory bulletin. Took them couple of hours and I was back on the road. It's been 100+ miles since they upgraded software and everything is fine so far.
 

·
Registered
Joined
·
14 Posts
O2 Sensor

I took possession of my new Golf TDI about a week ago. This morning, with about 150 miles on it, the check engine light came on.
In the time waiting for the car to arrive, I've been reading pretty much all the of the website and forums (Thanks Chitty for such a great work). I knew it was probably a problem with the O2 sensor, so I brought it immediately to the dealer without turning the engine off.
They read the code and told me there was a Bulletin advising to change the O2 sensor when that problem happens, so it seems it's a known issue. I'm now waiting for the parts to arrive. FYI, my car was built February 24 (yup it took forever to leave Germany, nobody knows why, but that's another story)

I'll try to get as much documentation as I can from the repair and post it here.
 

·
Registered
Joined
·
14 Posts
So I just got my car back after they changed the O2 Sensor and updated the software per technical bulletin.

Here is the info I got from my repair:

Cause: Diagnosed to Bank1 Sensor 2 Oxygen sensor, electrical malfunction
Technical Bulletin 2022741
Replaced Post catalytic converter oxygen sensor
Performed software update

I also asked for the diagnostic log, but looks like I just got the 1st page containing the 1st event of the 2 recorded:
Code: 05081 P13D9 000
Cylinder 4 internal pressure sensor
implausible signal
sporadic

I suppose the second one is the 02 sensor code. I'm wondering what that 1st one is. Maybe it's just noise due to the o2 sensor?

Here are the scan (anonymized) of the "invoice" and diagnostic log:



 

·
Registered
Joined
·
27 Posts
My new TDI just threw a MIL at 150 miles, so I'll have to take it in on Tuesday. Will post the problem cause. The car runs fine, no apparent problem, so might be the O2 sensor.
 
1 - 20 of 21 Posts
Top