VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner
1 - 6 of 6 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
How鈥檚 it doing everybody馃槉
I鈥檝e got a 2005 Vw golf mk5 just reCently purchased from police auctions,nice clean car but the downfall is the whole dash is pulled apart and the key is lost and the entire ignition has been smashed to bits.So I鈥檝e replaced it with another second hand ignition with anew ecm but it cranks and it want it start any info would Ben appreciated thanks
 

Premium Member
Joined
246 Posts
Your 2005 golf should be mk4
ECM, cluster, and rfid chip in key all have to agree
If the car runs for a second and quits it's likely the immobilizer.
From your description it sounds like you haven't gotten that far.
Make sure the lift pump is operating.
Remove hose from filter to hard line on the front of the valve cover and stick it in a clean container.
Turn key one click. You should hear the pump. If not lift the rear seat. A couple ounces of fuel should have gone into the container. If no fuel in container figure out why.
When you actually get the car to run at least for a second look for a flashing car symbol on the cluster. If it's flashing and the car is immobilized you have two options.

Buy a matched set cluster, ecm and key/ignition from a wrecking yard.

Or

Send your ecm to a tuner and have the immobilizer deleted. Much easier and around 100 bucks.
 

Premium Member
Joined
246 Posts
Just saw the Australian flag so totally unsure about the generation. It should still be a pd engine though.
 

Registered
Joined
3 Posts
Discussion Starter · #4 ·
Your 2005 golf should be mk4
ECM, cluster, and rfid chip in key all have to agree
If the car runs for a second and quits it's likely the immobilizer.
From your description it sounds like you haven't gotten that far.
Make sure the lift pump is operating.
Remove hose from filter to hard line on the front of the valve cover and stick it in a clean container.
Turn key one click. You should hear the pump. If not lift the rear seat. A couple ounces of fuel should have gone into the container. If no fuel in container figure out why.
When you actually get the car to run at least for a second look for a flashing car symbol on the cluster. If it's flashing and the car is immobilized you have two options.

Buy a matched set cluster, ecm and key/ignition from a wrecking yard.

Or

Send your ecm to a tuner and have the immobilizer deleted. Much easier and around 100 bucks.
Dave thanks mate I done what u said and more and it ended up the key.i had a bloke pop in and matched the new key to the car,problem I got now it cranks but the vdub want run?
 

Premium Member
Joined
246 Posts
It runs not at all or runs for a second? Is fuel getting to the engine? When these cars run out of fuel it takes a lot of cranking. Refer to previous instructions.
 

Registered
Joined
3 Posts
Discussion Starter · #6 ·
It runs not at all or runs for a second? Is fuel getting to the engine? When these cars run out of fuel it takes a lot of cranking. Refer to previous instructions.
It only cranks mate does not run as yet,I lent a scan tool and I done a complete scan and it stated cylinder glow plug 1, bad and 2,3 plug so I've bought a new set and ill let u know how I go thanks heaps mate
 
1 - 6 of 6 Posts
Top