VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 2002 golf tdi started sputtering around 2 years ago and continued off and on up till now where it is much worse and consistant. I used to switch the ignition off and on and that would cure it but now that doesn't work. I have taken the EGR valve of and given it a clean but the problem still persists. I read a thread from someone who was experiencing the same symptoms on their golf tdi and it was the VNT actuating arm that was sticking causing the problem. Anyone any advice out there on this prob?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for your reply Fluid. I've checked out the page you gave me and I think it could be the turbo that is causing the limp mode.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I cleaned the EGR valve, breaking the plastic actuator arm when I was ring to prize it open to unhook it from its mounting, managed to fix it with some superglue gel and a tight wrap with evostick ultra sticky tape. The EGR was not as clogged up as I thought it might be for 158000 miles on the clock but I have always used BP ultimo low sulphur diesel since I bought the car at 78,000 , which apparantly prevents excessive build up of carbon deposit on EGR and manifold intake. Probably could to with a clean, just haven't had the time to do it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Took the car to the garage. Mechanic put it on the VAG-COM. 2 faults messages displayed on VAG-COM. Injector and injector wiring. Replaced the injector wiring harness and job done, problem solved. Cost £155
 

·
Registered
Joined
·
1 Posts
Hello, I know this is an old thread but can you tell me if your golf is still running ok only I have the same problem but it's not showing any error codes. Thanks.
 
1 - 8 of 8 Posts
Top