VW TDI forum, Audi, Porsche, and Chevy Cruze Diesel forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I recently purchased an automatic 2002 Golf TDI with a bad head in hopes to swap motors with a totalled manual 2001 TDI I have. The motor was working after the car was totalled. Anyways, I swapped the motors and transmissions, driveaxels, ECU & main (large, left) ECU harness. I rewired the 175 relay according to a page documenting an auto to manual swap, to enable reverse lights, cruise, and clutch cancel switch. I bled the system. I went to turn on the car and I was getting the immobilizer icon (I thought due to swapping ECUs? Any way to get around this?) and flashing glowplugs. I swapped the ECU & main ECU harness again, with the original automatic ones from that car. I wasn't getting the immobilizer icon this time but when I turned the key, I still did not have any starter activity. I tested the started and it is working fine. I read about issues with the 109 relay, which I'll try replacing next. I did have MIL lights with both ECUs

Is there anything else I should be looking for? I figured you guys might know. Any help would be greatly appreciated!
 

·
Super Moderator
Joined
·
23,902 Posts
Relay 109 symptom is no glow plug relay light on the instrument cluster.

Immo has nothing to do with the starter so if the engine doesn't crank it's something else. I believe relay 109 also lets you crank the engine, there just won't be any fuel or engine control. The brake or clutch switch could be faulty.

Did you swap the instrument cluster back? The instrument cluster and ECU are tied together. Also, 2002 was a transition year for immo2-immo3. they cannot be swapped. Look through the immo2 FAQ article for details, long story short, if you see the vin number you have immo3.
 
1 - 2 of 2 Posts
Top