1. Welcome to myturbodiesel.com, if this is your first visit, please read 1000 answered questions - TDI FAQ, DIY, and Wiki by clicking the link here or in the navigation bar above. Click the "Sign up Now" button to the right to create an account, registration is fast and free.
  2. After you create a free account, every subforum has reply boxes. Here is a thread showing how to create an account or post a new question, shown with pictures

Oil Pressure Problems??

Discussion in 'VW Mk4 Jetta, Golf, New Beetle, Passat TDI forum' started by hogluvr, Mar 12, 2011.

  1. hogluvr

    hogluvr New Member

    Joined:
    Feb 8, 2011
    Messages:
    26
    Car:
    2001 New Beetle
    I was driving my new (to me) '01 Beetle for the first time, got off the freeway after about a 15 minute drive, and my oil light and buzzer came on, then went off after a few seconds, did it again a few minutes later. I took it out the next day, no light. Started driving it to work (100 mile round trip), no light for three days, then flicked on for a second after day three. Is this something to be concerned with, is it a sign my oil pump is going bad? Car has 173,000 miles on it, checked the oil and level is fine...
    login to remove this ad
  2. chittychittybangbang

    chittychittybangbang Administrator

    Joined:
    May 23, 2007
    Messages:
    20,925
    Car:
    2006 Jetta TDI
    Location:
    CT
    It could be either the oil pressure sensor, low oil pressure (worn bearings or worn pump), or chafed wiring.

    Any mechanic shop should be able to measure the oil pressure. I believe VCDS should have the oil pressure reading in one of the engine measuring blocks but you need that tool to view this information.

Share This Page