2000 Jetta TDI Overheating

Discussion in 'VW Mk4 Jetta, Golf, New Beetle, Passat TDI forum' started by ImXCanadianXEh, Dec 12, 2017.

  1. ImXCanadianXEh

    ImXCanadianXEh New Member

    Joined:
    Dec 12, 2016
    Messages:
    3
    Car:
    2000 Volkswagen Jetta TDI
    Location:
    Fort Erie, ON
    Mods:
    VNT 17/22, Bosio Race 520, Stage 3 Malone Tune, EGR Delete
    I have 2x 2003 Jetta Wagon TDI's
    Recently had the timing belt, water pump, studs, etc replaced.

    both have seemed to devolp the same problem since then.

    They both seem to overheat, Have since then replaced the radiator, thermostat 3 times (All 3 Replaced with OEM Thermostat)
    Burped the coolant system, confirmed hose's are routed properly, Burped coolant system again, and still overheating. and lower radiator hose staying cold.

    Any Insight on what it could be

    Both car's had the Hepu timing belt kit installed
    its getting really frustrating
     
  2. oil rides

    oil rides New Member

    Joined:
    Apr 3, 2016
    Messages:
    15
    Car:
    VW Jetta 1999
    Location:
    Storrs, CT
    Maybe try it out without a thermostat see if the lower hose gets warm
     
  3. Dave N

    Dave N Member

    Joined:
    May 31, 2015
    Messages:
    71
    Car:
    06 Golf TDI BEW 09A
    Location:
    Spokane Wa
    You don't put the thermostat in backwards by chance did you?
     
  4. mgoff5000

    mgoff5000 Member

    Joined:
    Feb 27, 2012
    Messages:
    232
    Car:
    2000 Jetta 5-spd, 2004 Passat Wagon
    Location:
    SF Bay Area
    Mods:
    Jetta is on H&R Sport/Koni Yellows, Skid plates on Jetta/Passat, BSD and cam replaced on Passat
    If this developed in BOTH cars after having the same maintenance done then I've got to suspect either the kit or the work. That's just really low odds that something else went wrong on both cars.
     
  5. ImXCanadianXEh

    ImXCanadianXEh New Member

    Joined:
    Dec 12, 2016
    Messages:
    3
    Car:
    2000 Volkswagen Jetta TDI
    Location:
    Fort Erie, ON
    Mods:
    VNT 17/22, Bosio Race 520, Stage 3 Malone Tune, EGR Delete
    The one car I did a heater core flush on, and fixed the issue. The other not so much luck :(
    Trying to avoid replacing water pump but pulled off coolant line the one car was steady stream at idle, the other was kinda just intermediate
     

Share This Page